home *** CD-ROM | disk | FTP | other *** search
/ SGI Developer Toolbox 6.1 / SGI Developer Toolbox 6.1 - Disc 4.iso / public / fax / src / dist / flexfax.spec < prev    next >
Text File  |  1994-08-01  |  3KB  |  82 lines

  1. #    $Header: /usr/people/sam/fax/dist/RCS/flexfax.spec,v 1.18 1994/04/27 22:14:37 sam Rel $
  2. #
  3. # FlexFAX Facsimile Software
  4. #
  5. # Copyright (c) 1990, 1991, 1992, 1993, 1994 Sam Leffler
  6. # Copyright (c) 1991, 1992, 1993, 1994 Silicon Graphics, Inc.
  7. # Permission to use, copy, modify, distribute, and sell this software and 
  8. # its documentation for any purpose is hereby granted without fee, provided
  9. # that (i) the above copyright notices and this permission notice appear in
  10. # all copies of the software and related documentation, and (ii) the names of
  11. # Sam Leffler and Silicon Graphics may not be used in any advertising or
  12. # publicity relating to the software without the specific, prior written
  13. # permission of Sam Leffler and Silicon Graphics.
  14. # THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, 
  15. # EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY 
  16. # WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.  
  17. # IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR
  18. # ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND,
  19. # OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS,
  20. # WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF 
  21. # LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE 
  22. # OF THIS SOFTWARE.
  23. #
  24. define CUR_MAJ_VERS    1006        # Major Version number
  25. define CUR_MIN_VERS    003        # Minor Version number
  26. define CUR_VERS        ${CUR_MAJ_VERS}${CUR_MIN_VERS}${ALPHA}
  27. define FAX_NAME        "FlexFAX"
  28.  
  29. include flexfax.version
  30. include flexfax.alpha
  31.  
  32. product flexfax
  33.     id    "${FAX_NAME} Facsimile Software, Version ${FAX_VNUM}"
  34.     inplace
  35.  
  36.     image sw
  37.     id    "${FAX_NAME} Software"
  38.     version    "${CUR_VERS}"
  39.     subsys client default
  40.         id    "${FAX_NAME} Client Software"
  41.         exp    "flexfax.sw.client"
  42.     endsubsys
  43.     subsys server
  44.         id    "${FAX_NAME} Server Software"
  45.         # need DPS fonts and VM startup file for ps2fax
  46.         prereq (
  47.         dps_eoe.sw.dps        1006000000 maxint
  48.         dps_eoe.sw.dpsfonts    1006000000 maxint
  49.         )
  50.         exp        "flexfax.sw.server"
  51.     endsubsys
  52.     endimage
  53.  
  54.     image man
  55.     id    "${FAX_NAME} Documentation"
  56.     version    "${CUR_VERS}"
  57.     subsys relnotes default
  58.         id    "${FAX_NAME} Release Notes"
  59.         exp    "flexfax.man.relnotes"
  60.     endsubsys
  61.     subsys readme default
  62.         id "${FAX_NAME} README Notes"
  63.         exp "flexfax.man.readme"
  64.     endsubsys
  65.     subsys client default
  66.         id    "${FAX_NAME} Client Manual Pages"
  67.         exp    "flexfax.man.client"
  68.     endsubsys
  69.     subsys server
  70.         id    "${FAX_NAME} Server Manual Pages"
  71.         exp    "flexfax.man.server"
  72.     endsubsys
  73.     subsys doc
  74.         id    "${FAX_NAME} Supplementary Materials"
  75.         exp "flexfax.man.doc"
  76.     endsubsys
  77.     endimage
  78. endproduct
  79.